200E Dash Lighting

Hi All,
Lighting behind ALL my interior switches won't work (switches themselves do). From extensive research(!) the bulbs behind the vent controls, mid dash switches, window & mirror switches, & S/R are all
on the one circuit. However there doesnt appear to be a fuse for these. Everything else is working fine.
Has anyone experianced this? Any pointers / known weak points in this circuit (please!) ? I've taken apart the dash, tested bulbs etc but now am stuck. Im reluctant to give to a hack electrician, but cost of MB Dealers is prohibitive.
Many thanks for any help here
N. (1991 200E)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had taillights that wouldn't work at all on my 240D - what I had to do was take apart the taillight, and I found that the metal circuit etching had cracked in several places, breaking the circuit. I dropped some hot liquid metal in each of the cracks, then used JB Weld to fix the metal in place. Everything works now, but for how long, I don't know.
Hope this helps.
snipped-for-privacy@oceanfree.net (MrG) wrote in message

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I had that happen on 81 300D for the dumest reason...the lighting plug behind the speedometer vibrated loose.Replugged it with a bit of silicon sealer to override viberation and the entire dash and tranny hump lit back up.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.