260E Stalled & won't Restart

Hi,
I would appreciate some ideas on what to look at in repairing my 1987 260E.
For a few weeks it would intermittently stall while at an idle, or while
driving it would loose power for a 5-6 seconds then stall(smooth shut down). It always restarted and ran all day until recently. Last Sat. it stalled and won't restart. It trys to start but it seems like it's not getting any gas.
Does the above symptom point to a certain part?
Anyone have any ideas? I'm thinking it's either:
Clogged fuel filter- Where is it?
Bad Fuel pump - Where is it?
Bad fuel pump relay - Where is it?
Thank you for your assistance.
David
--
--
David Black < snipped-for-privacy@earthlink.net>
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Most probably the fuel pump relay is broken. The get tired after many years of service and no longer hold their ON position. Otherwise the fuel pump becomes the suspect.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yep, fuel pump relay... check the date stamped on the relay... it is probably the same year as the car was built.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.