300 E Mercedes-benz

I was driving today it was 15 mintues my driving, all the warning light turned on. And my stering start jaming then car could not move. THen I turn off the engine and then start again, then it all work
fine. I just don't understand what happen. Anyone please please help me. I just want to know why it happen, engine oil is fine. Car is ran fine after I restart the engine.
Do I need to take the car for check up. What should I do,
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Classic symptom of a failing overload relay... only solution is buy a new one. It is located behind your battery .. with a red fuse on the top.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thank you for your answers!
Is it possible to change by myself. Is this need instant check or can wait for few days before taking it for service.
thanks you.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The part is $55 at the dealer... pull the cover out... remove the battery for easier access... two screws... slip old out... slip new in and reverse.
Very easy
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.