300 SD Hot Relays!

Attempting to get my recently acquired car road worthy and have encountered what to me is a strange problem. Several of the relays in the fuse box get
hot... real hot... can't touch hot if I leave them inserted. I have several things disassembled at this point and am not sure which relay goes to what. If I let them cool and plug them in I can get all four windows to work. Let them heat up, and the driver's window will not work!
Any thoughts/ideas/help? I have ordered a couple of relays in the hope that will fix it. If not, I will have spares...
Wingnut
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Windows motor do take alot of amperage... which will make it heat up fast... I would check the fuse first... make sure it is the right fuse specified by MB... not too high.
Then I would check the wiring harness at the switches to see if any tampering.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I would check the electrical systems voltage while running. See if that is too high?
Marty
PS could also be a partial short somewhere.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for all the responses. I will try some of them out this weekend when I get back to the ranch.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.