300D fuse problem

I have an 1987 300D and my #3 fuse keeps blowing every week or so. My right side parking lamp, tail lamp, and instrument cluster illumination goes out.
Any idea what this could be and advice on how I could track it down?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Most likely an intermittent short to ground. A loose wire could be hitting a body part and pulling too much juice and the fuse blows. Can be hard to find sometimes. I had a turn signal that blew everytime you turned it on, which was a bit easier since I knew what device caused it. Could not find the actual wire with the problem and had to run a new wire to the turn signal.

--
-----------------------------------------------------------
Fred Emmerich
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Fred has the right idea, but a solution would be to adapt a automatic re-setting circuit breaker fuse to the fuse holder. Check the fuse sectiion at your local AutoZone, Kragens, etc. Otherwise you may never find the short.
fred snipped-for-privacy@comcast.net wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks. That may just be the ticket because it's been a few days now that I've driven in the dark with no problem - the new fuse is still good. I didn't realize such a thing as an auto resetting circuitbreaker existed.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.