300D shift flare

Hi,
I have an '83 300D that I purchased from the original owner with 140,xxx miles. The car overall is in great shape, however the transmission is
starting to act up a little. It currently has about 160,xxx miles. On the 3-4 shift it sometimes revs a little under partial throttle. Under full throttle or light throttle it is fine. I have adjusted the pressure cable on top of the engine and I still get this. It is probably time for a rebuild?
Also, I have heard conflicting information about the fluid to use, although I haven't checked with the dealer yet. What fluid seems to work best?
Thank you
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
how about second to third shifts? mine have been doing this for 3 years now and they have not gotten any worse
was told after fluid & flter changes it may need a valve body
the case, minus a few cans!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Fluid is Dextron... but feel free to use any semi or full synthetic fluid.
I would adjust the modulator so it shift firmer... by adjusting the cable, you are adjusting when it will shift... at higher or lower RPM.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You probably are not getting enough vacuum. Ihave 244k miles on my tranny and it works like new. I removed the EGR valve and upped the vacuum hugely. P.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.