300D tran problem - advice?

Hi Have 1984 300D with 310K on it....very good condition, strong runner. Developed a transmission problem in the past few days...shifts normally until the last
shift up, and then stays there until RPM gets up to about 4500-5000, then it shifts into drive. For a few days, this was the only problem...it would act normally cruising until I slowed all the way or stopped. Today it has the same symptoms, EXCEPT if I am running at 80 mph (for example) at about 3500 RPM, and then slow down to 60'ish and the RPM drops below about 3000, it kicks down a gear and the RPM jumps up to 4500 until I speed up again and puch the RPM to the high 4500-5000 shift point.
Any advice? Anal maintenance at dealer, but transmission has never been replaced
Chuck
300C 1984 560SL 1987 E500 2003 ML500 2003
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Change your filter and fluid first. I actually would change the fluid 2 times to flush out old tranny fluids out before finally change the filter and last top up of fluid. During each change, drive the car for a while before draining again.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
CEmely wrote:

Have the screens cleaned, fluid replaced and the level checked with a hot transmission. If the problem persists, ask here again for the next diagnostic step.
I have a 76 NB that was seriously neglected. Two fluid changes solved all my problems.
JJ
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had the same problem. A fluid and filter change on the transmission fixed it!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.