500SEC Periodically/Randomly doesn't start

I have a 1984 500 SEC Euro version. Over the past few months it has not started about once a week. The starter turns the engine over but it never starts. Afterwards I can smell gasoline. Once this occurs the car usually
won't start again for several hours sometimes a day. I'm not sure if the engine is getting too much gas, not enough gas, or if there is something causing the spark plugs not to fire. Unfortunately this happens randomly so I've never been able to make it happen when I take the car to my mechanic. Other than when this happens, the car runs great, starts immediately and has lots of power, etc. The problem does seem to occur more frequently during wet, cool weather. Can anyone tell me of a potential cause of this problem?
Lyle
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like it is ignition related. Check distributor cap and rotor for moisture, wear and carbon tracking. Next time its wet, try to start the car. If it doesn't start right away, spray WD-40 on wires and cap. Try to start again. If it starts up, you have your answer. If cap/rotor/wires are 4-5 years old or have 75-100k mi on them change 'em!
Dick
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.