'83 300D vacuum locking weird behavior

My '83 300D turbo is behaving strangely due to some vacuum leak that I cannot pinpoint... The locking system behaves as follows:
- With the A/C and heater off, engine takes a while to shutdown,
and afterwards every door needs to be manually locked (seems there is no vacuum in the system at all)
- Pressing any of the climate control buttons (except OFF) while the engine is running seems to close the vacuum leak, as the engine can be stopped immediately and locking the driver's door from outside automatically locks the other 3. However, vacuum stored seems to be minimal since further unlocking and locking of the driver's door leaves passenger side front and back doors unlocked.
- With the climate control button on and the engine running, the driver side doorlock can be pressed and the other 3 will be automatically locked as well. Then, if I try to stop the engine with the doors locked it will take a long time, and when it finally stops the 4 doorlocks are unlocked automatically and they need to be locked manually (locking the driver side door from outside does not propagate to other doors at this point).

the vacuum leak might be?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.