'84 300SD Squeak from Rear(?)

Hey there, I make a right turn, it squeaks like crazy. Left turn, nothing. My wife decided to drive it around with the E brake on for a couple of days before this sound appeared. I suspect this is not releated. The
half shafts seem very tight when I grab them and try to wiggle them. CV boots are good. Brakes, oddly enough, have pads left and seem fine. I'm leaning toward the CVs since I have replaced them on other MB cars with little drama--and I always hope it's something low drama that I've done before. Any input would be appreciated. Thanks for your help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Wheel bearing.
--
"Ward, weren't you a little hard on The Beaver last night?" --June Cleaver


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My Oregon Shop ha scritto:

Maybe a schock absorber is locked? Try to push down the rear left side of the car and listen to the noise. Also, try the right side and compare the effort.

Mmm... wheel ball bearings mught be cooked... and brake pads won't be happy, too. Jack car up and try to move rear wheels, to check the ball bearings.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.