87 300SDL stopped shifting

Well I decided to sell my 87 300SDL and everthing seemed to be working fine. So the first guy that comes to take a look takes it for a test drive, and
guess what - about half way through the drive it stops upshifting from first gear.
At first he could get it to shift, but now it won't get out of first gear for anything.
I have read some about the modulator vacuum line and fluid levels. Does this sound like a vacuum problem or something more serious with the transmission.
Thanks for any help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Check the downshift button- it may be stuck in the kickdown position. It is on the floor under the accelerator pedal.
Bill Ditmire Ditmire Motorworks,Inc. 425 White Horse Pike Absecon,NJ 08201 http://www.ditmire.com 609-641-3392
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks, that was it. I never hit the accelerator pedal hard enough to kick it in, I guess. I did notice he was flooring it on the test drive.
Does this need to be replaced or can it be lubed with something to make it work correctly - it still sticks?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Just work it a couple dozen times. That oughta do it.
Bill Ditmire Ditmire Motorworks,Inc. 425 White Horse Pike Absecon,NJ 08201 http://www.ditmire.com 609-641-3392
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.