88 MERZ 260E WONT START

I had trouble with it starting 3 months ago. It was going dead then start back up after a few turns. I thought I fixed the problem with a new fuel pump relay and now it wont start at all. I noticed that when I turn the
ignition key to the on position, I here a non stop buzz/humming noise. It sounds like its coming from under the glove box, I can feel it buzz/humming when I touch under the glove box. Could this have anything to do with the car not starting? Is there anything under there like another type of relay of some kind, or is it coincidental.Any tips on how to check some things it might be? Trying to pinpoint this before taking it to the dealer, dont want to have them telling me and trying to fix everything under the hood. Thank you for your response!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have the same yr and model car. I had the same problem with it not starting. I heard buzzing sounds also. Long story short, after trying to start it 5000 times, I took the Distributor Cap off and was greeted by water! Dried it out and voila....working fine, started on the first try. Note: the gasket behind the cap was broken allowing it to suck in moisture. O-ring seems to be available from dealer only.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.