92 190E 2.3 - foul smell in the air circulation system

Hi
I have a 92 190E 2.3 and in summer (I'm in Alberta, Canada...yes its only a short portion of the year that the problem exists..) there is a foul smell
present when the car is first started. It is especially bad if the air conditioning is NOT on. What also happens is that when I wash it, the smell of the soap or wax used is present for a few days and then the foul smell comes back .
Anyone have any ideas about how to track this problem down. It seems like there is a filter somewhere that is holding the water and as it goes stale, gives off the smell.
Thanks C. Peters
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You might want to try turning off the air conditioner about 1 minute before you park to prevent the problem in the future (works for BMWs). Richard

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You might have a dead critter in the air duct where air enters into the cabin... Otherwise, you need to use evaporator cleaner.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Turn on the heat or the air and spray some lysol into the heater intake (at the bottom of the windshield,outside), some times you can get some mold growing in the heating/ac system, the lysol will kill it, no more stink. ;)
WD

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
lysol really works!!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.