94 C280 Problem - no air from center vent

I have a 94 C280 and recently I discovered that the center vent has no air coming out. I tried all the setting and speed on the max also. I tried to unscrew the 2 screws beneath the
radio to remove the center wood plate but unsuccessful.
Does anyone know if there is a separate blower for each air outlet or the valve is malfunction. How can I fix it myself? It is now getting hot and I would like it fixed soon. Any help would be appreciated. Please also email me just in case I miss it in the newsgroup. Thank you all.
David snipped-for-privacy@mail.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
David, Open your hood, passenger side in front of the windshield lift that big plastic lid that covers most of the electronics, near the right shock tower you'll see a little 2 1/2 inch X 1inch plastic box with 4 hard plastic colored lines inserted, the colors are white, green red and grey, the valve is mounted with a 8mm screw to the firewall that seperates the engine compartment, remove that screw, turn the valve upside down, you'll see a crack on the bottom of the valve...replace it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.