95 MB C280 Rough Idle

I have a 1995 C280, it will run fine when started but after driving for a while the idle will become rough to the point of shaking the engine. If I turn the engine off and start it up again it clears up but its' temporary.
Will get it's rough idle back again and restarting clears it up.
Any suggestions on what this might be?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Possible vacuum leak that's diluting the air / fuel mixture in one or two cylinders to the point of misfire. You notice it only at idle because it's a small leak and at speed becomes a tiny percentage of the air allowed into the engine. Listen for a hissing sound, check the various hoses connected to the intake manifold, particularly the small ones.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
When is the last time you had your oxygen sensor replaced? What mileage do you have now? It is quite urgent to fix this as it may damage your cat converter and that will cost you a bundle.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the info, I have 117,000 miles on this one. I also do feel a difference when running at high speed as well as an idle. Don't know if that will help explain anymore or not

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If you have not replace your oxygen sensor at this time... I suggest you do so... It is possible that your cat is plugged... making idle like crap due to high back pressure.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.