96 E320 Starting Problem

Several times in the last few months I have had intermittent starting problems. The engine turns, but doesn't start. It eventually does start. Seems like its not getting fuel. I changed the fuel filter, and thinking
about the pump. Does this car have a fuel pump relay? Any other suggestions? Thanks,
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
All MB has fuel pump relay. Eventually starting as if you keep cranking. When does this happen? When engine is cold or hot?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Hot or cold. Started this morning, drove about 10 minutes, stopped and wouldn't start. Eventually did after about 8 trys and about 10 minutes. Last week it happened after work when the car had been sitting for 8 hours.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
This a sad note. I know someone who is having a similar problem with a 2000 M320. I feel it is more an indication of the lower quality and reliability of Mercedes, in general.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like overload relay is bad.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

What OVP ??.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ooops... I need to clarify something a bit more... when you said stop... you turned off the engine? Or it cuts out on you?
If you turned the engine off, then you got hot start problem. Meaning one of your fuel injector is leaking.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
When the engine fails to start, is the engine cold or hot?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Hot or cold. Mostly hot, but has happened cold also.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.