ABS and Spedo Fault

Hi,
My father has a 1996 C250 Classic Diesel Saloon (UK Market). The ABS light is on all the time whilst driving and the spedometer does not work. I was wondering if these are related. Does this model use the
ABS wheel sensors to generate a signal for the spedometer, and if so which one (or all)? Anything else it might be? What would I need to diagose a faulty sensor? I have a DVM and oscilloscope, but what signals / voltages should be present.
Many thanks in advance of any reply,
Jon Symonds
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No speedometer uses ABS signal to get speed... it is all from tranny.
I suggest you check your overload relay fuse first... usually when this is blown, the ABS light will come on.
Speedometer problem can be fuse related... take out the fuse and replace it with a new one.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks for that, do you have any idea where it is located on this model?
Much appreciated,
Jon.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
All the fuses are in the hood area... in the fusebox. Open up your owner's manual and it will show you where... or search the internet if you don't have a manual.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.