Air Cond 500 SEC

Have a problem with the air conditioning in that the compressor is not engaging when the air Cond is switched on.
Wires to the compressor and switches in the dryer are OK and will not
activate the compressor.
If the compressor is wired directly from the battery it works and cools.
Tried to trace the wires back but I'm lost at the fuse/relay box.
The fuse in the box although OK is hot.
Is there a relay (which one) or another fuse which I should be looking at.
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yes, the car does have an AC Compressor Relay.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check your A/C pressures. The compressor has a built in line safety switch. Once it senses pressure going down on the "suction" side (20 psi or less) it will NOT let the compressor come on. the reason for this cut out is, they don't want the compressor running empty, because the oil will "migrate" out of the compressor and will into the evaporator. Mechanical items don't work with out oil.
PS. You've probably have a leak in your system. Bring your car to a reputable mechanic.
Bill

at.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Wildman wrote:

There are two switches on the dryer one to the fan and another which i assume is the pressure switch.
Even if I short this out it does not allow the activation of the compressor.
When the compressor is manually operated a wire from the battery to the terminal on the compressor it will operate and cool the car.
Rob

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
German Star wrote:

I'm thinking it maybe this - which one is it - there is no relay pattern in the fuse box for the relays.
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the SUCTION LINE PRESSURE. Most (if not all) the gas is gone.
Bill

at.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.