C220 Condenser or Auxiliary Cooling Fans

Anyone know why my C220's condenser fans are not turning on? There's no power going to when its needed to turn on. I was going to replace the fan relay/module but theres no telling if thats whats bad. Any thoughts??

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
There's a temperature sensor, a fuse, a relay and the fans - take your pick of which is defective. Hint: Start with the cheapest to replace.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
the fuse is ok, I am assuming the fans are ok only b/c when the system calls for cooling I chkd the terminals going to the fans and theres no power. This tells me that the relay is not sending out power to the fans. So, I am down to the relay. I don't know where the temp sensor is. And I believe there is another electronic module (the brain) that communicates with the relay. I have an appmt with the dealer tomorrow. I think i'll just have them take care of it ;o(. Very apprehensive only b/c it might be be expensive.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ok!! Dealer narrowed it down to a damaged electrical connector/module located inside left wheel well just under the front fender. $10 part, $95 labor. I am happy with their work and they even don't mind me repairing it once the part comes in. They are pretty confident this is whats wrong.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.