central locking '95 S420

central locking doesn't work anymore. alarm activates and the doors will self close, but i can't lock all the doors at once, and the trunk opener doesn't work (the trunk's tongue is sticking out all the time now). is this
a vacuum pump problem? where is the pump located on this car? i understand they're very $$ from mercedes. any suggestions appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Central locking pump is under the rear seat, right side. There is a modification you may need to do when you replace the pump.....

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yep, sounds like a vacuum pump alright.
I don't know where it's located, but they are fairly expensive. Probably around $1000 or so with labor.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
First, listen to the pump when you activate the door locks. Does it sound like it's running. If it's running for an extended period, you may just have a leak in one of the plastic vacuum lines. Check for leaks before replacing the pump.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
thanks, all, for the tips. good ones. is there more than one component in the locking system? that is, could it be a problem in something other than the vacuum system? i looked on the ADSIT site and they have pumps and some other thing listed in the central locking section of their site. don't want to replace the wrong thing.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.