Check Engine

I recently purchased a 99 C280. I have order the owners manuels but they haven't arrived yet. On the way home tonight the Check Engine light came on. There wasn't any smoke, steam, knocks or drips. The engine starts fine.
But, the light come as soon as the engine starts. Any ideas or suggestion? I plan to call the dealer tomorrow. But, would like to get a head start.
Alan snipped-for-privacy@satx.rr.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Try tightening the petrol cap first. It's common cause for CHECK ENGINE light to illuminate. In addition, it's usually the OBD II that's the cause. OBD II is particularly sensitive to whatever is not within its prescribed perimeters...
Oliver
Alan Johson wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Get a tank of fresh hi-test and give a while to see if it goes out. O2 sensor can occasionally trigger check-engine light.
Scott D

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Disconnect the power for ten minutes then see if it comes back on. That will at least let you know if it was a temp. problem.
Good Luck
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Get a right mechanic to reset the obd memory, It only cost less than NZ$50. Only the "computer" can tell what set off the lamp.

will
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.