comand aps navigation

Hello,
I have a Mercedes W211 (2004), with the comand aps navigation... for the moment I am still using the old Dvd Version 2.3. A friend of me has bought a new Mercedes same model and also with the comand
aps navigation and including the new Dvd Version 7.0, When I put his Dvd in my comand the comand failed to read the Dvd... So before i by a new version of the software and spent some money on it, has anybody any id why my comand won't read the Dvd.
Comment on the backside of the cover (compatible with E-klasse ( 03/02) another comment * Comand Software update 30/06 (W/S 211, C129, R171) is required. Do I first need to install a Software update or what means it.
Thanks Rc.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.