Corrupted Mercedes in California

Just wondering what the most logical solution to this problem on my 99 C230 Kompressor might be. My gas gauge works about half the time. It is totally unreliable- my daughter and son both have run out of gas
because it's so goofy.
Anyway, this vehicle had spent most of it's adult life in California and I'm wondering if the fuel additives there may have corrupted the sending unit- you know- Many things can become corrupted in California!!
Or would this more than likely be an electrical problem?
I'll hang up now and listen for your answers.
Thanks RexD
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Actually it is a pretty common problem on the C and E class at that time period... something with a bad manufacturing defect. The only solution is to change the gas level device in the gas tank.
Also, there has been a rash of epidemics of fuel gauge not working correctly on all makes of cars and model year of 1996 and newer cars just recently... expecially in Tennessee... some in Ohio... some in Kentucky... something due to quality of gas although it was not one specific brand... it is a wide range.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.