Cruise Control Issue

87 300D 2.5 Turbo
Today when coming home from some thrifting (hitting the city thrift shops) my cruise turned on max. I couldn't turn it off by hitting the
brakes. So I pulled off the road. When I shifted into Park the engine went to a high RPM. I turned it off before it went too high. Restarted right away - RPMs went high, so I turned it off again. Waited 5 minutes (to let the vacuum subside) and restarted. It started fine and the cruise was finally off.
Thoughts on what to check? Or should I just shell out and replace all the vacuum hoses under the hood? ;-)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It sounds like the turbo ran away. There is a air pressure limiter (may not be the right MB term) on the intake manifold, a hexagon about 22-25 mm size. It turns off the signal to the injection pump to stop the extra fuel. The limiter, wire or the vacuum may be in fault.
The operation: The boost from turbo calls for more fuel. More fuel produces more power, faster rpm, more exhaust. More exhaust turns turbo faster and it in turn makes the boost even higher. Therefore, never overlook this safety device.
Cheesehead wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I agree... your turbo safety device is not working or bypassed.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.