Does this make sense to anyone?

I have a 1983-85 Mercedes 230E that has a bit of quirky problem.....
Every now and again, when driving along, the power will suddenly drop off, and when the car slows down sufficiently, the engine just cuts out......Yet
when I restart the engine, it works fine again for a while before doing it again......
It only happens under very definite circumstances......Firstly, it only happens when I lift my foot from the accelerator, or when the revs are dropping.....Never on accelaration or when the revs are high......
Secondly, and this is the most puzzling of the two circumstances......It only ever happens on hot sunny days.......I have joked with my wife that the car sffes from hay-fever......
Has anyone got any idea what could be the cause of this problem?.....It's most annoying.....
Cheers
Sam www.fatwasam.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

off,
it
problem?.....It's
of
normally
I'll have a look see.....The RAC man we calle dout on the A1 told us it may be something to do with the fuel system, but he couldn't say for sure.....We've been minimizing the problem as best we can by adding Redex to the fuel, but it's not an ideal solution.....
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.