E320 cdi gear not changing up when cold

Any ideas would be appreciated. When the weather has been cold my car seems to be stuck in 1st (with high revs) for a couple of miles until warmed up. After that and on warm days all has been fine. No error
messages coming up except service B due (it isnt) Any idea whether I can leave this now the weather is warmer or if its something that will get worse? Its happened a handful of times in the last couple of months. thanks
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Completely normal... engine should revs high first thing in morning... to warm up the cats faster and better fuel economy faster.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

what cats are on a cdi?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You don't know that MB diesels have catalytic converters since 1995?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

i guess not
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.