gauges and dash lights not working

My friend has a 1982 300sd. The car's great, except that the gauges fluctuate wildly. Sometiems they work, other times they swing all over the place. Also, the dash lights and radio do not work. Could
this be a ground problem? If so, how do we check? Where is the ground connection?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Most likely fuse problem... look for it in fusebox and throw it away...put in a new one.
Ground is just behnd the cluster... you gotta pull it out to get to it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
NO, apparently the fuses are fine. The gauges work sometimes, but they also randomly fluctuate up and down.
snipped-for-privacy@siu.edu (Tomas) wrote in message

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like you have a bad ground. The radio might be a seperate problem. I'll bet where the negative battery cable grounds is not a solid ground. I ended up mounting mine under the air breather to the engine itself. There is another ground that goes from the transmission to the body, and that very seldom is the problem, but the fluctuating gauges goes hand in hand with a bad ground, as does a dead battery after ya drive it, if that is happening also. Jim
--
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com ).
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.