glow plug fault/extraction problems

I have just had my 93k mile C220 2002 C class B service carried out and the number 2 and 3 glow plugs are seized in. (I believe the garage may have snapped them whilst trying to replace because they said the
bottom part is jammed in carbon) The car has always started no problem, runs like a dream and the only fault is the glow light comes back on after start for 15 seconds as it has done for the last 15000 miles. I have been told mercedes have a specialist tool to extract this bottom portion? is this true or does the head have to come off for drilling out? Any Help would be great.
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Also check the O2 sensor reactions... make sure they all work.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
There should be tools to extract it... without taking the head off... depending on how deep it is in...If you are saying they got the threaded part out but not the rest... well... probably have to take head off...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.