Glow Plugs '82 300SD

The glow plugs on my '82 300SD just went out. The orange dash ligh indicator does not come and the the car requires lots of cranking to start, so it seem all the plugs are out. This happened suddenly.
I think there is a 50 amp fuse somewhere I can check, but haven't located it yet.
Any ideas on where to start to find the problem. I'm a competant mechanic with the tools I need, inculding electrical. Just need to know where to start.
Had this car since new with very, very few problems.
Thanks,
Wayne
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mounted on the left fender is the glow plug relay - a black box with wires going to its bottom. It has a plastic cover that slides UP exposing the 80 amp fuse or fusible link. These can be bought from the dealer and others for about $1.
In an emergency the link can be jumped with a heavy copper wire, but it's not a permanent repair.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It's an 80 amp fuse. Check with a volt meter to see if there's any voltage at the glow plugs. If there isn't then you indeed need a new 80 amp fuse.
--
Richard Sexton | Mercedes Parts: http://parts.mbz.org
http://www.mbz.org | Mailing lists: http://lists.mbz.org
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.