H reg Mercedes SE 300 auto., looses power after 70mph

My car drives well up to 70mph.As soon as I try to go over 70mph it looses power. I have taken it to a Mercedes garage but they cannot find any problems.
The car has done 35k and has been serviced.
Any pointers please?
Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
awas wrote:

Check your fuel filter.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Similar to Thom's 3/24/06 post on this NG. Suggest you look at it.
When was your car's fuel filter last changed? Probably never, given the low mileage.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Fuel filter(s).
--
Need Mercedes parts? http://parts.mbz.org
Richard Sexton | Mercedes stuff: http://mbz.org
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

That will be the Mercedes benz automatic top speed controller fitted to the 300SE models specifically to stop speeding. My data books show me that only one vehicle was fitted with this option and was sold to Freddy Mercury of Queen fame.
not
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I wonder what you mean by this.
I have a settable speed limiter on my cruise control stalk. (Auto gearbox)
Two options:
- constant-speed cruise
- uncontrolled speed with top limit.
DAS
For direct contact replace nospam with schmetterling
--
"Roger" < snipped-for-privacy@who.net.au> wrote in message
news:LUKWf.20045$ snipped-for-privacy@news-server.bigpond.net.au...
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi awas,
Did you find out the problem?
I also have H reg 300 SE of similar mileage, and strangely have similar problem. I experience loss of power if I go up hill or above 60 mph especially when trying to overtake. I can't get it past 60.
I had car in the merc specialist who checked fuel sysyem up to ECU and could not find the problem. Someone mentioned it could be the torque converter but I am bot so sure.
Hence I am very interested to know conclusion of your problem
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi awas,
Did you find out the problem?
I also have H reg 300 SE of similar mileage, and strangely have similar problem. I experience loss of power if I go up hill or above 60 mph especially when trying to overtake. I can't get it past 60.
I had car in the merc specialist who checked fuel sysyem up to ECU and could not find the problem. Someone mentioned it could be the torque converter but I am bot so sure.
Hence I am very interested to know conclusion of your problem
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'm having a similar problem with a 420sel. Won't rev above 3000 revs in top gear. Wondering if it might be in the dist cap and ignition related? Otherwise will change fuel filter to see if that amends problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.