HELP! 124 Rear Window

Hey all,
It seems the rear left window on my 87 300D won't come back up. Fuse is good, have switched switches -- no joy. It sounds like the window motor
could be clicking but it won't let the window move. Any emergency ideas on how to get the window up so no one steals my beloved problem child?
-Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Have you tried using your rear window switch on the door ? Make sure the child lock is not activated by trying the other side.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The switch that you push activates a relay and that relay may be bad. The problem is to locate the relay! Look of a 1.5 inch square aluminum box near the fuses. There may be several, all with the same number, interchange them and you may get the window up.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks guys. The window miraculously went up after another hour of playing. Previously, I tried swapping all the switches and trying all of them... nothing. Opening and shutting the door to jar the cables was the last thing I tried. The motor has always had a much louder sound than the other windows, so it might just be going out.
Question: does that relay control ONLY the left rear window? All of my other windows work fine. Is it 1 relay per window?
-Mike

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The relay controls two windows... not one... in cross direction.
I suspect it is only the switches that needs to be disassembled to clean up all the contacts inside it. Very common problem for oxidation to build up so that you have problem closing a window.
It is not that hard of a job to disassemble and clean it up.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I opened the shitty switches and they looked good enough. Plus, I pulled two working switches and swapped them in, no joy.

up
so
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.