Help! My 87 190D NA Engine rattle more than I have ever heard it in 12 years

All,
In all my years owning this car I have never felt what I experienced Monday morning. The engine started up just fine, however it was shaking the entire
body of the car, and tons more noise than the clickty-clack that we all know and love. Not only this the shaking was so violent that I threw the serpentine belt (belt remained in tact). I drove it straight home 1/4 mile, since it started getting hot quick. When I got home shut it down, let it cool, it started back up, with lots more noise and shaking than I could stomach. So back off until I can get some Ideas on further analysis as to the possible root cause. I am hoping this is a manifestation of a one or more bad injectors. I had just made the decision to get a replacement set of rebuilt injectors to supplement my next oil change (the motor did not smooth out as much with my last diesel purge treatment). What would this motor experience if I had one or two injectors go bad?
Could this be a timing chain issue? Can not figure out what would have caused the belt to jump. The motor was doing the herky jerky thing. A member of another group feels that this may be the cause. He also suggested that the vacuum pump may be the culprit, but I do not think the motor would have shut off if this was the case. Maybe the guts of the pump are breaking loose, the pump was replaced with new MB part 150,000 miles ago. I am afraid to start the motor until I can figure out how to better diagnose this issue. If this does not sound like an injector issue, I am wondering how do I diagnose other issue. Push rod, valve, lifter, timing chain, vacuum pump, or worse.
What does everyone think? Has anyone experienced anything similar from this motor?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
How many miles / kms has this engine done?
Does the engine use (lubricating) oil?
Is the lubricating oil changed regularly?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mobile 15W 50 change every 3000 Miles
200,000 on motor

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
loud as a plane & no power?
my guess the chain jumped a few teeth and ya now have A LOT of bent valves
case
the case, minus a few cans!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.