Help: Starting Problem With 92 300E

My car suddenly started to have internitent starting problem. Battery has had plenty of cranking power but motor either starts with lots of difficulty or shut down while stopping at red lights. Finally it
didn't start at all. It is towed to Benz dealer. From all previous messages, my thought was on fuel line (filter, pump, relay) but mechanic says they are all ok and he also gets spark but no starting. He finally called and said he thinks it may be a control box that contorls ignition. I have no part number but he said the part runs close to $1000 (US)! Any suggestion what that part would be and any other thoughts. Thanks a million. Adam
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Change the Over Voltage Relay
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@aol.com (AJDalton7) wrote in message

Thanks. Can you tell me how over volt. relay goes bad? I used one full tank of midgrade gasoline (89 US octane) few weeks before this happened. Is there any relations? Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My 300te was acting this way recently but main clue was that when it quit, it had no spark. The control unit was shutting down when the sensor reading was bad. Then sometimes it decided things were OK and would crank up. Here is the story and a simple way to test:
alt.auto.mercedes "300TE stalls and won't start - faulty crankshaft sensor" http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&selm=rPSsa.25501%24fM2.7641%40fe07.atl2.webusenet.com
btw, if it is indeed a bad control unit you can find used ones at salvage yards and ebay for much less than that.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
OVP is common fault .. the problem is from bad solder joints in relay.. Some guys resolder ... I change them b/c there has been a part improvement/upgrade,,,
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.