Hood ..here I was thinking of wheels

Howdy, My new acquisition runs great, however now the hood won't open. I pull the plug in the cockpit, but now the thingee doesn't pull out in the grille. Had my
wife pull in the cockpit, I pushed/pulled on the hood. Damn it's stuck. Now what do I try? Perhaps a broken cable. Can I reach a release from oz? Down Under? Somewhere? Surely some other poor soul has faced this. Thanks, Adysthemic
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Best bet is to look at the hood latch and find that cable so you can pull more than what the handle can pull for you. Put a tool where the cable rides on so it has more tension.
Once you get it open, adjust the cable tighter... there is an adjustment sleeve on that hood release cable.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I could not find the adjuster sleeve. I did however take your advice about "pulling" more. I took the inside puller off it's pivot so I could pull further. That popped it. I took it apart but no adjuster I could see. I moved the plate on the hood a fraction and lubed the cable with Tri-Flow. All works well.,Adysthemic
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Congrats!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.