Idle

Please Help!!! I have a 1986 190E 2.3. It idle "ok" in neutual and park but in drive it idle rough. I replaced the plugs, wires, distributor cap
and rotor. Any suggestion??
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

What is the idle in Neutral, Park and Drive? If you have the idle set too low, it can cause the engine to "shimmy" or feel as if it's running rough.
Compare your idle speed with the factory specs - you may just need to raise it a bit.
--
Scott Gardner

"Nothing's ever easy." (Ron Gardner)
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Don't forget to consider the engine mounts. If the engine is ok (e.g. revs fine in neutral) but gives you a slight vibration when you put it in gear then the mounts (which are fluid filled and leak over time) might be the cause.
Josh
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Remember, this engine has only four cylinders so if one is less than 100% it will drag the engine down.
You've done the ignition side, now it's time to look at the fuel delivery and air / fuel ratio.
Have you tried some fuel injector cleaner in the fuel?
Fuel injectors can be professionally cleaned.
Check for a small vacuum leak - hose connected to the intake manifold or the gaskets between the intake manifold and cylinder head.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.