Idle Speed Suddenly Too Fast - Advice Please !!!!!!!!!!!!!

For seemingly no reason at all, my 300SE (W126) has decided to idle at ~ 1200 rpm instead of her usual 600 rpm. She does this hot and cold. Apart from that she is running and performing as before. What's going
on, where do I start looking to slow her back down?
All help and comments greatly recieved :) Mike
--
W126 300SE
W115 220/8
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check for simple mechanical possibilities - that the throttle linkage has free movement over its range and that - don't laugh, it's happened - the floor mat isn't pressing the accelerator.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Two possibilities, 1 is way more possible that the other. It's either the idle control valve, or the idle control unit. I say there's a 95% chance it's the idle control unit. I know on the 1985 380SE its a black box up by the firewall, but for some years it's behind the glovebox so yours might be there. It's a fairly expensive part, so you might want to get a used one (i got mine from pgauto.com) or look for a refurbished one. Richard

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.