intermitten wiper not working

89 560SL What might be the most probable cause and cure of the intermitten position for the windshield wipers doing nothing? (Slow and Fast work fine.)

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The switch fails first and is the most usual cause of problems.
--
Need Mercedes parts? http://parts.mbz.org
Richard Sexton | Mercedes stuff: http://mbz.org
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check if the cable came off the control box under the dash near the brake pedal.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Would that not cause all the other functions of the switch to stop? Only my intermittent wiper feature has stopped
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
John 560SL wrote:

That was exactly the problem in my 450SL. Only the intermittent did not work and the wipers would not self park. Problem was that the cable plug was disconnected from the control module. I suspect that previous owner was trying to shoot a battery drain problem as several other plugs were also disconnected on the car.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is there a way to test it?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I'm not familiar enough with the SL you have to say of an easy way. But, if you drop if off here ar my house, I'll seuss it out fo ryou and by fall we'll now for sure. Aww hell, I'll jsut fix it for you nice guy that I am.
Failing that...
Common sense says take it off, and apply a voltmeter. With the schematic you might/should be able to find the wire that signals intermittant operation and check that out with a voltmeter.
--
Need Mercedes parts? http://parts.mbz.org
Richard Sexton | Mercedes stuff: http://mbz.org
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.