Low engine rpms at idle for 93 190E 2.3L

I have a 93 190E 2.3L and when I put the thick oil 20W-50 this past June 2005 I noticed that the engine would on occasion idle and vibrate at a low rpm after initial startup and at other times it would idle low
at a stop when the car engine was warmed up 100 C and had been driven for over an hour.
Is it the oil that is the problem or something else???
Any ideas?
CP
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It's not the oil, IMO.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

    I agree, not the oil. Do, however, have a look at the fuel pressure regulator valva bolted on the side of the air intake to see if it's leaking. Do you smell a little gas??
cheers, guenter
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Are you sure its on a 93 190E 2.3L?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, it is a small valve (approx. 1 inch diameter, 2 inch long) with the fuel return line connected to it. It is actualle at front of the air intake (air filter assembly removed).
Anyway, the idle speed is controlled by the engine computer (thereby not adjustable) through the idle speed air valve, which is located behind the air intake and fixed to the intake manifold by a rubber piece. Check also if all tubes around it are correctly fitted.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.