MB valve body question...

I am about to install a used transmission in my 84 190e ... because after a very expensive 'flush/filter/fluid' change, trans began 'flaring' over 3rd
and going quickly to 4th. The clutches seem fine on this box ... car drives very nicely if shifted manually ... would it be worth while to remove and check valve body first, and look for problems? although I would not know what exactly to look for ... anybody have a diagram or schematic I believe it is the 722.400 trans. I appreciate any help from the experts ... JC
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I think I'd try replacing all the springs I could with beefier heavy dute ones. The kits to do this are all over ebay.
http://transmission.articles.mbz.org/k1 /
If that doesn't fix it then I'd tear into it and replace the valve body.
--
Need Mercedes parts ? - http://parts.mbz.org
http://www.mbz.org | Mercedes Mailing lists: http://lists.mbz.org
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I can't help you now, but I can help you in the future. NEVER,NEVER let anyone FLUSH a transmission. Change the oil and filter but never FLUSH with one of the new finagled Flushing machines (if that is what you mean by "flush".} I have seen quite a few transmissions fail right after they were flushed.
Paul Paul's Auto Electric
wrote:

a
3rd
drives
believe
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.