Mercedes misfires after the car is washed or wet from rain.

After our 2003 Mercedes SLK320 has been washed or sets outside after a rain the car starts up but misfires like it is running very rich and the Check Engine Light comes on. Older cars acted like this when an automatic choke
was stuck closed or the manual choke was pulled out to far. When I turn off the engine and then restart the car everything is fine and the engine runs fine and after driving awhile the Check Engine Light turns off. Took it back to the dealer twice. First time they said it was the k5 relay, they changed it. Second time they said it was the ignition wires on #6 cylinder. Does any one have a clue for a fix of this problem???
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You need to check the OBDII DTC's to get a clue.
Peter

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You know it is rain related so you need to find out what get wet in this circumstances...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Answer back to "Tiger". You are right something is getting wet or colder such as an ambient or engigine temperature sensor. That's what I am seeking to find. The dealer stated that the car computer stated it was due to a k5 relay. This was corrected and still the matter is uncorrected. So it is back to the dealer again unless some one out there can shed more light on this so I can obtain a better direction and understanding on this subject. Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.