Navigation: can't input specific address??

I recently acquired a 2000 S500, and I've found that while the navigation system will let me input a specific address (house no.), it then forces me to choose from a list of address ranges (e.g., 101-149,
150-199, etc.). I assume I must be missing something? Or is the system just old and not as precise as others I've used?
Thanks for any help! Devon
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You can buy new navigation CD with more up to date map and info.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yep, because that's all they know... so if you got something like a new construction on new street... it might not even show up... for up to 3 years. It will only show up if you buy new map.
Other time, you need to double check the street prefix... Ave. and St. are different.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
jdoe wrote:

Will an updated CD help, or it just a limitation of the system itself?
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

more than likely a new cd would change nothing
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
As far as updated map and addresses, yes. As far as the system improvement, slight.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.