Navigation system trouble.

When I press the NAVI button, the screen gives me the message, Navigation could not be activated--an error has occurred. There is a CD in the device,
and it won't eject.
I tried poking around in the slot with a Popsicle stick, but no help. I have considered giving it a big shot of WD-40, but am not sure that might cause more harm than good.
Does anyone know of a possible solution short of a jillion dollar charge at the dealership.
Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
How about telling use the year, model, and miles??

device,
at
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sorry, it's a 2000 S430, 90k miles.
Mike

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Don't go for the WD40 approach ;-)
Sometimes the CD gets stuck against the lip of the slot and needs something like a business card judiciously applied to ease it out.
Assuming you can get the CD out, switch off COMAND using its own switch and then switch off ther ignition for a couple of minutes. Switch everything back on and reinsert the CD. That may just do the trick. If it doesn't try cleaning the lens in the unit with a cleaning disk. They are known to be picky over any contamination.
Good luck.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.