No Climate control functions W126 Please help

Hi. We are parting out a W126 and sold a climate control unit to a gentleman on eBay. It was functioning when we removed it. The customer installed it
and still has no blower, no AC clutch engaging, no AC, no heat, it's just dead. He said he checked the fuse and it's OK too.
Anyone have any suggestions?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I think it is obvious that he had a bigger problem that has nothing to do with the climate control unit. First of all, no blower... ask him to turn unit on... EC or AC... and set fan speed to high. Then under the passenger side dash... give it a whack... if fan comes on, then fan motor is bad. If fan doesn't come on... then have him check the fan fuse... take them out and inspect it... and put a new one in.
Don't just look while in place... look is very decieving.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

that will solve his problems.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Different model year may use slightly different climate control unit. At least on W201, the later years even have more pins on the connectors.
BTW, what year/model/color is your W126? I may be interested in some parts, mostly interior. TIA
Keyser Soze wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

interior is tan (palomino). The exterior is black. We purchased it as a parts car to cannibalize for our damaged 89 420.
The car is in northern NJ. Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.