No heat 1988 separated dual console 420 SEL

Hi again,
Is the heater monovalve insert the copper thermostat-like valve with 2 intakes on 1 side, 1 on top and one outlet to the manifold? It seems to not work. We removed it and placed water through it and it did not go through all inlets/outlets - one did not operate. Now, it seems dysfunctional because one goes to a solenoid controlled valve, with 4 screws to open - but - the outlets on this were cold, as if being not fed, but the top metal housing was screaming hot, so we assumed the valve was getting necessary electric supply but no antifreeze? . We removed that valve and placed direct power (jumped from the battery) and it did open. It worked. When looking on the internet, we see repair kits available but this copper valve with the 4 inlets/outlets is one piece and definitely not repairable. It is spring controlled like a thermostat, and when shaken when cold it makes a rattling noise. Any suggestions here please?
Best regards,
Tony Pike J J
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
{size:8.5in 11.0in;} .ExternalClass div.EC_Section1
</STYLE>
<DIV class=EC_Section1> <P class=EC_MsoNormal><FONT face=Arial color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">Hi again,</SPAN></FONT></P> <P class=EC_MsoNormal><FONT face=Arial color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Is the heater monovalve insert the copper thermostat-like valve with 2 intakes on 1 side, 1 on top and one outlet to the manifold? It seems to not work. We removed it and placed water through it and it did not go through all inlets/outlets one did not operate. Now, it seems dysfunctional because one goes to a solenoid controlled valve, with 4 screws to open but the outlets on this were cold, as if being not fed, but the top metal housing was screaming hot, so we assumed the valve was getting necessary electric supply but no antifreeze? . We removed that valve and placed direct power (jumped from the battery) and it did open. It worked. When looking on the internet, we see repair kits available but this copper valve with the 4 inlets/outlets is one piece and&nbsp;definitely not&nbsp;repairable. It is spring controlled like a thermostat, and when shaken when cold it makes a rattling noise. Any suggestions here please? </SPAN></FONT></P> <P class=EC_MsoNormal><FONT face=Arial color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; Best regards,</SPAN></FONT></P> <P class=EC_MsoNormal><FONT face=Arial color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </SPAN></FONT><FONT face=Arial color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">Tony Pike</SPAN></FONT><FONT face=Arial color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">&nbsp;&nbsp; </SPAN></FONT><FONT face=Wingdings color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Wingdings">J</SPAN></FONT><FONT face=Arial color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">&nbsp;&nbsp;&nbsp; </SPAN></FONT><FONT face=Wingdings color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Wingdings">J</SPAN></FONT><FONT face=Arial color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">&nbsp; </SPAN></FONT></P> <P class=EC_MsoNormal><FONT face=Wingdings color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"></SPAN></FONT>&nbsp;</P> <P class=EC_MsoNormal><FONT face=Wingdings color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">My monovalve&nbsp;went bad some years ago, and the MB dealer put a 'repair kit' into it. Check with the parts dept at your Benz dealer.</SPAN></FONT></P> <P class=EC_MsoNormal><FONT face=Wingdings color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial">John</SPAN></FONT></P> <P class=EC_MsoNormal><FONT face=Wingdings color=navy size=2><SPAN style="FONT-SIZE: 10pt; COLOR: navy; FONT-FAMILY: Arial"></SPAN></FONT>&nbsp;</P></DIV></FONT></DIV></BLOCKQUOTE></BODY></HTML>
------=
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.