OM603 Knocking Noise

Hey All,
My 87 300D (OM603.96) just picked up a horrible knocking/rumbling noise... the other day, I was low on gas and time and went to a usually reliable
station and picked up a few gallons, drove about 50 miles, then noticed an occasional sound like rocks rumbling around in the engine. It was present at idle but I couldn't hear it when the revs increased. Tried filling up with a dependable fuel source (Arco ECD-1) which was about 15 gallons, and was en route to do an italian tune-up when the noise got worse (about 2 miles from the fill up). Sounded like there were more rocks, and there was a whirring/grinding noise that was RPM dependant as well. Got it home and let it cool down and restarted it, the knocking is back to how it was when it first appeared -- random, like rocks in a cylinder or something.
Car has full power, no smoke, no ill effects whatsoever besides the noise. 202k mi running Mobil 1 synthetic. Head is possibly cracked but not very bad, and the car has been overheated once in my ownership. Have cracked all of the injectors and they all hurt the idle but don't take the noise away. The noise sounds like its coming from the underside of the engine, near the oil pan area or just behind. Prefilter has some small debris but nothing big nor numerous. Pulled the primary filter, dumped it, and did the long crank to refill it -- cranking sounds completley normal (none of the noise). Catalyst was replaced before I bought the car and the EGR system has been disabled.
Any ideas whats going on, or how to troubleshoot?
Thanks! Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Hmmm,
That doesn't sound good... usually in my experience if it is as you described a clunking sound from the oil pan area, The likely candidate is a main bearing...
Good Luck, and let us know, Marty
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Broke out the stethescope and went looking around... to my (pleasant) suprise, it was the alternator. The thing was self destructing inside.
Never woulda suspected...
-Mike

was
all
the
noise).
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.