Parking Light Problems

Hi, My '98 E320 is just over 10 years old. I recently had to have the high-beam bulb changed on the passenger side (the side that's almost impossible to get to). I had it done at a local independent M-B
specialty shop. Then, within a week or two, the parking light bulb in te same housing needed to be repaired - same shop. Then, after about another 3 weeks, both side parking lights do not go on. I don't believe in cooincidences, so is there another issue here, e.g. possibly a connector or switch problem? Thanks in advance to anyone who has insight into this problem.
--
Frank M.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Frank - I would say you are very lucky not to have had to change any of these bulbs (if you are the original owner) in 10 years! I have a 2001 E320 and have been through 1 headlamp, 1 tail lamp and 2 fog lamps in the 8 months I've owned it. Poke around at the various MB forums and you will find a lot of people talking about the recurring lamp changes! Part of being an MB owner...
I will say that on the tail lights, on some models, there is an issue with the sockets heating up and changing shape which affects the electrical contacts. Hasn't seemed to affect mine.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.