PLEASE HELP ME WITH A CLASS 140

Hi,my a class stopped on me last week,when i try to start it the revs surges and then it stops if i keep reving it i can keep it running but it smells rich,i took it to a garage and they are beaten with it,I
have sent the air mass sensor away to be checked at bbr-reman and it tested ok, when you can drive it at some speed you can keep it running but when you slow down or stop the revs surge for a while and then she cuts out :cry: has anybody any idea what can be wrong with it,could it be a sensor or somthing :? i really need my car at the moment because we are expecting a baby soon :D If anybody has any ideas please help, Thanks, Andy.
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You believe the motor is being over fueled, I suggest you consider:
a vacuum leak between the air mass sensor and the intake manifold, including vacuum hoses attached to intake manifold
O2 sensor
over voltage protection relay (OVP).
Meanwhile, borrow/rent a car to avoid additional anxiety.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.