Please help, urgent...C280 Sport

Hi, and thank you very much for taking your time to read my request for help.
It is a C280 Sport, 2000, 40,000 miles - it has been to the shop (warranty) for at least seven times now, with the same problem.
The car often goes into limp mode and I have to shut it down to reset the system. It is often very slow and the 'check engine light' is on. Now, MB claims that they replaced the 'whole' engine, and it do not turn into limp mode or anything, but I still think it is slow, it is a V6 after all...I opened the hood here tonight, I see an old silver bumped piped that I do not remember seing before, sticking out on the right side, and the engine do not look new or anything to me. I am going crazy about this and MB will or can not fix the problem. I live in Florida so maybe the problem is that they do not have any qualified technicians to fix the car.
If anybody have any idea what I can do I would be very, very happy to hear from you.
Also, the car has been at MB for almost seven weeks, is that allowed, I mean, that long time???
Here is what they have done to the car at the latest service: 141310 Intake manifold r & r 1108 w, cable harnes 076520 Fuel inj. valves - all r & r / repl. if req 1108 w 547940 Repl. engine wiring harness 1108 w 011321 Engine cylinder bores - all inspect with borescope 1108 w 012800 Engine with autom. trans., r & r 1108 w 014370 Engine short block - fitted with pistons (????, Brian) only repl. 1108 w 071628 Fuel inj. control module - all fuel inj. systems, repl. 1108 w
, seal ring, sender unit, 10 sealant, seal, rubber mount, 10 trans fluid, screw, seal ring gl, hose, rocker arm, cover crankc, gasket, pin bushing, crankshaft b, connecting r, preassure rel, thermostat e, filter eleme, antifreeze (????, Brian), switch, control unit, spark plug b.
All this do not seem to me as a 'new engine', but I might be wrong, my car knowledge is really very limited - but, if any one can help me, I would really, really, be happy and if I get any success with this, I will award somebody, serious!!!
Sincerely Brian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
S class is the only way to go.
keep bitching & call LAWYER
case
82 300sd
the case, minus a few cans!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@webtv.net (IF YOU CAN'T SWIM DON'T JUMP IN) wrote in message

Thanks for the help...though I could not use that advice for much...Anyway, Mercedes are talking about taking the car back with the money back.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 19 Sep 2003 17:27:42 -0700, dk snipped-for-privacy@hotmail.com (Brian) wrote:

I think "limp mode" has something to do with the transmission.
Go here, join, and ask the same question:
www.mbworld.com
www.bnzsport.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.