Problems with my 500SL

My transmission seems to be slipping. Still strong on highway and whenever car has momentum. Slips when stopping and turning. Reverse wont engage until
engine is reved-up. Seems better when cold? Adding fluid causes smoking! Do you think changing the fluid and filter may help?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Simply adding fluid will cause more harm (more is not better in this case). Assuming that it hasn't been done in a while, take your car to a mechanic and have the fluid and screen changed before more damage is done. Then assess if the tranny is slipping.
Josh
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check fluid level and add if necessary. Otherwise, it sounds like you need a rebuild.... what is the current mileage?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Current milage, 153,000. Tiger wrote:

--
Message posted via http://www.carkb.com

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Reverse not working us *usually* a sign that it's new tranny time. You could try changing the oil and filter - that's cheap and easy to do.
But be prepared to find a good used trans or have it rebuilt.
--
Need Mercedes parts? http://parts.mbz.org
Richard Sexton | Mercedes stuff: http://mbz.org
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.