R & R 190E FUEL INJECTORS

Just finished replacing O2 sensor, cleaning, and regaping plugs (less than 1000 miles) distributor cap and rotor, Big, Big change in pep and drivability. 1992 2.6 still has a stumble after starting,
raising idle speed smooths it out. Suspect leaky injector seals. At 124,000 miles, new injectors may be due as well. Are t]here any red flags for a DIY on this? I understand the fuel rail is pressurized On a 1 to 10 scale this job would be ?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
A stumble when the engine is started or when starting out (accelerating)?
Usually a stumble is due to a too lean air / fuel ratio. It may be wise to have a shop check and adjust the air / fuel ratio as THAT may be the real problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
When I had the front end of my 190E 2.6 apart to replace the belt tensioner I noticed that the temp sensor inside the air intake had a lot of crud accumulated on it. I carefully cleaned it before I put everything back together. Maybe it is my imagination but the car appears to be running much smoother and idle speed is up slightly.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Peter is right on the track... your engine temperature sensor for fuel injection is bad... which is why your engine stumbles when cold or hot because fuel injection don't know how much gas to give to your engine depending on temperature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the replies guys I'll r&r the air cleaner first, and filter. My Performance products catalog, lists temperature sensor only up to '87....was there a change? haven't looked yet... btw what does the air cleaner buffer do...........rick
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
OOops?!.... temperature sensor, is now one of four screwed into top of engine under air cleaner,...they are thermostat vacuum valve, auxillary fan switch, temperature sensor water gauge, and temperature sensor CIS from '88, black four prong....$24.50
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
There you go...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The sensor I was referring to is right after the cold air intake by the radiator in the plastic ducting before it joins with the air cleaner. You should be able to spot it easily as it has a connector with wiring coming from it. At least that is what I have on my 92 190E 2.6

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.